192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

VLAN配置及VLAN间路由的概念和实操

发布时间:2016-11-19 15:20
同“路由器-交换机-终端”的概念是相同。VLAN主要是为了同一物理局域网内隔绝广播用的。
它允许局域网内不同交换机上相同VLAN中的机器通信,隔绝其他VLAN的广播。
VLAN间要通信则要配置VLAN间路由,不配置路由,分属不同VLAN、配置为相同网段的计算机也不能通信。
在三层交换或路由器上为每个VLAN配置一个与相应VLAN连接的路由器接口,路由器通过自己这些VLAN接口进行转发。每个接口相当一个逻辑上的路由器,同路由器一样也是为了连接不同网段,所以不同vlan要配置不同网段的IP。

 
一、工具软件:Cisco Packet Tracer 7.0
二、实验拓扑图:
说明:a、switch2、switch3均为24口交换机,将它们的fa0-8划为VLAN 1,fa9-16划为VLAN 2,fa17-24划分VLAN 3
    b、switch1的g0/1连接switch2的g0/1,switch1的g0/2连接switch3的g0/2

 
三、IP地址规划:

 
IP address subnet mask gateway 连接接口
VLAN 1 192.168.0.0 255.255.255.0 192.168.0.1
VLAN 2 192.168.1.0 255.255.255.0 192.168.1.1
VLAN 3 192.168.2.0 255.255.255.0 192.168.2.1
PC0 192.168.0.2 255.255.255.0 192.168.0.1 switch2 fa0/1
PC1 192.168.1.2 255.255.255.0 192.168.1.1 switch2 fa0/9
PC4 192.168.2.2 255.255.255.0 192.168.2.1 switch2 fa0/17
PC2 192.168.0.3 255.255.255.0 192.168.0.1 switch3 fa0/1
PC3 192.168.1.3 255.255.255.0 192.168.1.1 switch3 fa0/9
PC5 192.168.2.3 255.255.255.0 192.168.2.1 switch3 fa0/17
四、实验目标:创建VLAN 1、VLAN 2、VLAN 3,并且配置VLAN间路由,使VLAN间可通信
五、实验步骤:
a.switch2配置:
Switch#configure terminal
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#exit

 
Switch(config)#interface range fastEthernet 0/1-8
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 1
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/9-16
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 2
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/17-24
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 3
Switch(config-if-range)#exit
 
Switch(config)#interface g0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

 
b.switch3配置:
同switch2,将fastEthernet1-24口划到相应VLAN
Switch(config)#interface g0/2
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

 
c.switch1配置:
Switch(config)#interface g0/1
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#interface g0/2
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
(vlan间路由配置) www.luyouqiwang.com
Switch(config)#ip routing
Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.0.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 2
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 3
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#exit

 
六、网络连通性测试
把配置全部敲好再测试连通性不利于排查配置中的问题,应该是每配置好一段就进行测试。此处为了方便就单独列出。
从pc0 ping pc2,能通代表同VLAN通信没问题。
从pc0 ping pc1、3、4、5,能通代表不同VLAN间路由配置成功。


 

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明