192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

Cisco Packer Trace 之 三层交换机+路由器共享上网

发布时间:2015-03-06 11:30

实验目的:

1、在三层交换机划分三个VLAN,分别是VLAN2\VNAL3\VLAN4,并且设置VLAN IP 分别为:192.168.2.1、192.168.3.1、192.168.4.1。

2、在三层机上把fa0/1口设置为trunk口,fa0/4加入VLAN4,并且把f0/2关闭二层端口,并设置IP地址192.168.5.1。

3、设置二层交换机,把fa0/1口设置为trunk ,并把fa0/2加入VLAN2,fa0/3加入VLAN3。

4、在三层交换机上开启路由器,并设置RIP路由器协议,让各VLAN之间数据互通。

5、测试各VLAN的主机是否互通。

6、配置ROUTE0的IP地址,并测试各内网的主机是否可以PING通192.168.5.2。

7、因为路由器没有配置可达路由,导致内网的PC无法PING通192.168.5.2,此时我们可以配置路由器协议,使内网可达到路由器。

8、配置ISP路由器的IP地址,并且测试route0是否可以PING通ISP的IP地址202.1.1.2;还测试内网主机是否可以PING通ISP路由器的IP地址。

9、内网是不能PING通ISP的路由器IP地址的,只有在ROUTE0上配置NAT转发才能实现。

10、内网主机是否可以PING通ISP下面的服务器。

实验步骤:

1、在三层交换机划分三个VLAN,分别是VLAN2\VNAL3\VLAN4,并且设置VLAN IP 分别为:192.168.2.1、192.168.3.1、192.168.4.1。

Switch>enable

Switch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#hostname CoreSW

CoreSW(config)#vlan 2

CoreSW(config-vlan)#exit

CoreSW(config)#vlan 3

CoreSW(config-vlan)#vlan 4

CoreSW(config-vlan)#

 CoreSW(config)#int vlan 2

CoreSW(config-if)#

%LINK-5-CHANGED: Interface Vlan2, changed state to up

CoreSW(config-if)#ip add 192.168.2.1 255.255.255.0

CoreSW(config-if)#no shutdown

CoreSW(config-if)#exit

CoreSW(config)#int vlan 3

CoreSW(config-if)#

%LINK-5-CHANGED: Interface Vlan3, changed state to up

CoreSW(config-if)#ip add 192.168.3.1 255.255.255.0

CoreSW(config-if)#no shutdown

CoreSW(config-if)#exit

CoreSW(config)#int vlan 4

CoreSW(config-if)#exit

%LINK-5-CHANGED: Interface Vlan4, changed state to up

CoreSW(config-if)#ip add 192.168.4.1 255.255.255.0

CoreSW(config-if)#no shutdown

2、把fa0/1口设置为trunk口,fa0/4加入VLAN4,并且把f0/2关闭二层端口,并设置IP地址192.168.5.1。

CoreSW(config)#int fa0/1

CoreSW(config-if)#switchport trunk encapsulation dot1q 

CoreSW(config-if)#switchport mode trunk

CoreSW(config)#int fa0/4

CoreSW(config-if)#switchport mode access

CoreSW(config-if)#switchport access vlan 4

CoreSW(config-if)#no shutdown

CoreSW(config-if)#exit

CoreSW(config)#int fa0/2

CoreSW(config-if)#no switchport

CoreSW(config-if)#ip add 192.168.5.1 255.255.255.0

CoreSW(config-if)#no shutdown

3、设置二层交换机,把fa0/1口设置为trunk ,并把fa0/2加入VLAN2,fa0/3加入VLAN3。

Switch>enable

Switch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#vlan 2

Switch(config-vlan)#exit

Switch(config)#vlan 3

Switch(config-vlan)#exit

Switch(config)#

Switch(config)#int fa0/1

Switch(config-if)#switchport mode trunk

Switch(config)#int fa0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 2

Switch(config-if)#exit

Switch(config)#int fa0/3

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 3

Switch(config-if)#exit

4、在三层交换机上开启路由器,并设置RIP路由器协议,让各VLAN之间数据互通。

CoreSW(config)#ip routing

CoreSW(config)#router rip

CoreSW(config-router)#ver 2

CoreSW(config-router)#no au

CoreSW(config-router)#net 192.168.2.0

CoreSW(config-router)#net 192.168.3.0

CoreSW(config-router)#net 192.168.4.0

CoreSW(config-router)#net 192.168.5.0

 


6、配置ROUTE0的IP地址,并测试各内网的主机是否可以PING通192.168.5.2。

Router>enable

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#int gi0/0

Router(config-if)#ip add 192.168.5.2 255.255.255.0

Router(config-if)#no shutdown

Router(config)#int gi0/1

Router(config-if)#ip add 202.1.1.1 255.255.255.0

Router(config-if)#no shutdown

 

  7、因为路由器没有配置可达路由,导致内网的PC无法PING通192.168.5.2,此时我们可以配置路由器协议,使内网可达到路由器。

Router(config)#router rip

Router(config-router)#ver 2

Router(config-router)#net 192.168.2.0

Router(config-router)#net 192.168.3.0

Router(config-router)#net 192.168.4.0

Router(config-router)#net 192.168.5.0

Router(config-router)#default-information originate       //它的作用是给我们三层路由器分配一条默认路由出去!

Router(config-router)#end

Router#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.2.0/24 [120/1] via 192.168.5.1, 00:00:05, GigabitEthernet0/0

R    192.168.3.0/24 [120/1] via 192.168.5.1, 00:00:05, GigabitEthernet0/0

R    192.168.4.0/24 [120/1] via 192.168.5.1, 00:00:05, GigabitEthernet0/0

     192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks

C       192.168.5.0/24 is directly connected, GigabitEthernet0/0

L       192.168.5.2/32 is directly connected, GigabitEthernet0/0

 

8、配置ISP路由器的IP地址,并且测试route0是否可以PING通ISP的IP地址202.1.1.2;还测试内网主机是否可以PING通ISP路由器的IP地址。 www.luyouqiwang.com/cisco

 Router>enable

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname ISP

ISP(config)#int gi0/0

ISP(config-if)#ip add 202.1.1.2 255.255.255.0

ISP(config-if)#no shutdown

ISP(config-if)#exit

ISP(config)#int gi0/1

ISP(config-if)#ip add 202.1.2.1 255.255.255.0

ISP(config-if)#no shutdown

 

 

9、内网是不能PING通ISP的路由器IP地址的,只有在ROUTE0上配置NAT转发才能实现。

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#access-list 1 permit 192.168.2.0 0.0.0.255

Router(config)#access-list 1 permit 192.168.3.0 0.0.0.255

Router(config)#access-list 1 permit 192.168.4.0 0.0.0.255

Router(config)#access-list 1 permit 192.168.5.0 0.0.0.255

Router(config)#ip nat inside source list 1 interface gi0/1 overload

Router(config)#int gi0/1

Router(config-if)#ip nat outside

Router(config-if)#exit

Router(config)#int gi0/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#ip route 0.0.0.0 0.0.0.0 gi0/1

 

  

10、内网主机是否可以PING通ISP下面的服务器。

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明