192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

一个简单的NAT配置方法和命令行

发布时间:2014-07-12 21:46

在企业搭建网络中,NAT配置是必不可少的,NAT解决IPv4的不足问题,方法也简单,私网地址靠NAT功能转换为公网,来解决访问Internet.。
1、首先在pc机、web服务器配置IP地址。
2、分别在R1、R2配置端口地址 例如:
R1(config)#int fa0/0
R1(config-t)#ip add 192.168.1.1 255.255.255.255.0
R1(config-t)#no shut
R1(config)#int se0/0/0
R1(config-t)#ip add 211.1.1.1 255.255.255.0
R1(config-t)#no shut
R1(config)# router rip
R1(config-route)#ver  2
R1(config-route)#no au
R1(config-t\route)#nwtwork 211.1.1.0    \\这里只公告外部网络,内部网络不能公告,在互联网上是不认私网地址。
 
在R2上配置接口地址如下:
R2(config)#int se0/0/0
R2(config-t)#ip add  211.1.1.2 255.255.255.0
R2(config-t)#no shut
R2(config-t)#clock rate 64000
R2(config)#int fa0/0
R2(config-t)#ip add 211.2.2.1 255.255.255.0
R2(config-t)# no shut
R2(config)#router rip
R2(config-route)#ver 2
R2(config-route)#no au
R2(config-route)#network 211.2.2.0
R2(config-route)#net 211.1.1.0
 
在R1上配置地址转换如下:
R1(config)#ip access-list standard nat
R1(config-std-nacl)#permit any
R1(config)#ip nat inside source list nat interface Serial0/0/0 overload
R1(config)#ip nat inside source static tcp 192.168.1.2 80 211.1.1.1 80
R1(config)#int fa0/0
R1(config-f)#ip nat inside
R1(config)#int se0/0/0
R1(config-f)#ip nat outside

上面就完成了路由器的组网和NAT的配置,虽然没给组网图,但是大家可以自己尝试自己动手来进行实验。

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明