192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

路由器上反转多路复用的应用案例

发布时间:2012-01-20 10:40

虽然国内网络和宽带接入情况已经大幅度的提升,但是因为通信行业本身还是一个垄断性质很强的领域,带宽线路租用费用依然居高不下,影响了数字传输业务的发展。

为了解决这个棘手的问题,就需要在路由器中使用到复用器,把多个线路合成(复用)成一个更大带宽的线路,目前处于主流位置的思科Cisoco路由器的"Inverse MUX Application using Multilink PPP"就是针对这个情况推出的。

下面用一个实际的例子来说明,附带上配置文件:

RouterA
hostname RouterA
username RouterB password abc
ip subnet-zero
multilink virtual-template 1
!
interface Virtual-Template1
ip unnumbered Ethernet0
ppp authentication chap
ppp multilink
!
interface Serial0
no ip address
encapsulation ppp
no fair-queue
ppp multilink
pulse-time 3
!
interface Serial1
no ip address
encapsulation ppp
no fair-queue
ppp multilink
pulse-time 3
!
interface Serial2
no ip address
encapsulation ppp
no fair-queue
ppp multilink
pulse-time 3
!
interface Serial3
no ip address
encapsulation ppp
no fair-queue
ppp multilink
pulse-time 3
!
interface Ethernet0
ip address 10.17.1.254 255.255.255.0
!
router ripnetwork 10.0.0.0
!
end 
--------------------------------------------------


RouterB
hostname RouterB
username RouterA password abc
http://www.luyouqiwang.com/13416/
ip subnet-zero
multilink virtual-template 1
!
interface Virtual-Template1
ip unnumbered Ethernet0
ppp authentication chap
ppp multilink
!
interface Serial0
no ip address
encapsulation ppp
no fair-queue
ppp multilink
pulse-time 3
!
interface Serial1
no ip address
encapsulation ppp
no fair-queue
ppp multilink
pulse-time 3
!
interface Serial2
no ip address
encapsulation ppp
no fair-queue
ppp multilink
pulse-time 3
!
interface Serial3
no ip address
encapsulation ppp
no fair-queue
ppp multilink
pulse-time 3
!
interface Ethernet0
ip address 10.17.2.254 255.255.255.0
!
router ripnetwork 10.0.0.0


!
end

通过此方法,我们可将多条低带宽线路合并成为一条线路,并通过虚拟端口Virtual-Template 1进行数据的传输。按此方法配置完成后,我们会发现在显示端口状态(sh interface)时,凭空多出一个端口Virtual-Access 1,此端口的数据流量恰恰等于各实际端口的流量总和,并且通过它将数据流量均分到各个实际端口当中去。从而达到合并低带宽线路的目的。

此外,在配置此功能时,需要注意以下几点:

1. 此功能只能封装PPP协议。
2. 在interface virtual-template 1配置中,ip unnumbered Ethernet0可用ip address XXX(地址)来取代。

合理的利用路由器复用和反转,可以极大的减少线路租用的费用,以最经济实惠的价格获得最理想的上网乐趣。

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明